Resolved
Our Shop has been fully restored. Merchants can place orders as normal. We apologize for any inconvenience caused during this time.
Monitoring
Our Shop has been fully restored. Merchants can place orders as normal. We apologize for any inconvenience caused during this time.
Investigating
We are currently investigating an issue affecting our Shop. Merchants may experience difficulties placing orders. Our teams are actively working to identify the cause. Further updates will be provided every 30 minutes or as the situation evolves.